EasyApache 3.24.15 Released

C

cPanel

Guest
SUMMARY
cPanel, Inc. has released EasyApache 3.24.15 with FCGI version 2.3.9 and PHP versions 5.5.10 and 5.4.27. This release addresses the FCGI vulnerability CVE-2013-4365 with fixes to a possible heap buffer overwrite issue, and the PHP vulnerability CVE-2013-7345 with fixes to bugs in the fileinfo module. We encourage all FCGI users to upgrade to FCGI version 2.3.9, and all PHP users to upgrade toPHP version 5.5.11 or PHP version 5.4.27.

AFFECTED VERSIONS
All versions of FCGI versions before 2.3.9.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2013-4365 – MEDIUM

FCGI 2.3.9
Fixed a possible heap buffer overwrite issue related to CVE-2013-4365.

AFFECTED VERSIONS
All versions of PHP version 5.5 before 5.5.11.
All versions of PHP version 5.4 before 5.4.27.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2013-7345 – MEDIUM

PHP 5.5.11
Fixed bug in the file info module related to CVE-2013-7345.

PHP 5.4.27
Fixed bug in the file info module related to CVE-2013-7345.

SOLUTION
cPanel, Inc. has released EasyApache 3.24.15 with FCGI version 3.2.9, and the updated versions of PHP 5.4 and 5.5 to correct these issues. Unless you have disabled EasyApache updates, EasyApache will include the latest versions of FCGI and PHP automatically. Run EasyApache to rebuild your profile with the latest version of FCGI and PHP.

REFERENCES
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4365
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-7345
https://www.apache.org/dist/httpd/mod_fcgid/CHANGES-FCGID
http://www.php.net/ChangeLog-5.php#5.4.27
http://www.php.net/ChangeLog-5.php#5.5.11

For the PGP-signed message, see EA3 CVE 3-24-15-signed.

Continue reading...
 
Top