EasyApache 3.24.19 Released

C

cPanel

Guest
SUMMARY
cPanel, Inc. has released EasyApache 3.24.19 with PHP versions 5.5.13 and 5.4.29. This release addresses the PHP vulnerabilities CVE-2014-0237 and CVE-2014-0238 with fixes to bugs in the fileinfo extension. We encourage all PHP users to upgrade to PHP version 5.5.13 or PHP version 5.4.29.

AFFECTED VERSIONS
All versions of PHP version 5.5 before 5.5.13.
All versions of PHP version 5.4 before 5.4.29.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2014-0237 – MEDIUM

PHP 5.5.13
Fixed bug in the fileinfo extension related to CVE-2014-0237.

PHP 5.4.29
Fixed bug in the fileinfo extension related to CVE-2014-0237.

CVE-2014-0238 – MEDIUM

PHP 5.5.13
Fixed bug in the fileinfo extension related to CVE-2014-0238.

PHP 5.4.29
Fixed bug in the fileinfo extension related to CVE-2014-0238.

SOLUTION
cPanel, Inc. has released EasyApache 3.24.19 with the updated versions of PHP 5.4 and 5.5 to correct these issues. Unless you have disabled EasyApache updates, EasyApache will include the latest versions of PHP automatically. Run EasyApache to rebuild your profile with the latest version of PHP.

REFERENCES
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0237
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0238
http://www.php.net/ChangeLog-5.php#5.4.29
http://www.php.net/ChangeLog-5.php#5.5.13

For the PGP-signed message, see EACVE3-24-19-Signed.

Continue reading...
 
Top